npm install mongoose で ‘REPLACE_INVALID_UTF8’ is not a member of ‘v8::String’ エラーが出る

はじめに

 2015/10/06 時点で、CentOS7 に mongoose を npm コマンドでインストールしようとすると、タイトルのエラーが発生しました。mongoose が依存する kerberos のバージョンが 0.0.9 から 0.0.15 になったところでエラーが発生していました。
 解決策としては、

  • kerberos 0.0.9 をバージョン指定してインストールする

あたりになるでしょうか。

回避方法 その1

 エラーの原因である kerberos のバージョン 0.0.15 の代わりに、0.0.9 を指定してインストールします。

$ npm install mongoose kerberos@"0.0.9"

 package.json に記述する際は、dependencies に下記のように指定しておくとよいでしょう。

    "mongoose": "~4.1.10",
    "kerberos": "0.0.9"

コメントを残す

メールアドレスが公開されることはありません。

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください